星期五 , 2020-10-23
首页 > WordPress教程 > WordPress免插件实现前台注册功能

WordPress免插件实现前台注册功能

现在有很多网站是把WordPress作为一个CMS内容发布系统来用的,而CMS系统一般都需要有用户互动的功能。大家都不想用户直接访问WordPress的后台账户,而是让用户直接在前台注册和登录。目前市面上也有不少此类实现前台注册和登录的插件,其中Theme my login就是个比较靠谱的前台登录和注册插件。不过本文所要介绍的是如何免插件实现前台注册功能。以下是具体方法:

1、首先,我们需要以page.php页面为基础建立一个名为register.php新模板文件。可以直接另存page.php页面并将页面编码设为UTF8即可,并在页面顶部插入以下代码:


2、在register.php中的上述代码的下面插入以下注册表单处理代码:

/*
添加注册表单处理
代码来源: www.wpzhinan.com/jiaocheng/1789.html
*/
错误:请输入用户名。
';
} elseif ( ! validate_username( $user_login ) ) {
$error .= '错误:此用户名包含无效字符,请输入有效的用户名
。';
$sanitized_user_login = '';
} elseif ( username_exists( $sanitized_user_login ) ) {
$error .= '错误:该用户名已被注册,请再选择一个。
';
}
// Check the e-mail address
if ( $user_email == '' ) {
$error .= '错误:请填写电子邮件地址。
';
} elseif ( ! is_email( $user_email ) ) {
$error .= '错误:电子邮件地址不正确。!
';
$user_email = '';
} elseif ( email_exists( $user_email ) ) {
$error .= '错误:该电子邮件地址已经被注册,请换一个。
';
}

// Check the password
if(strlen($_POST['user_pass']) < 6)
$error .= '错误:密码长度至少6位!
';
elseif($_POST['user_pass'] != $_POST['user_pass2'])
$error .= '错误:两次输入的密码必须一致!
';

if($error == '') {
$user_id = wp_create_user( $sanitized_user_login, $_POST['user_pass'], $user_email );

if ( ! $user_id ) {
$error .= sprintf( '错误:无法完成您的注册请求... 请联系管理员!
', get_option( 'admin_email' ) );
}
else if (!is_user_logged_in()) {
$user = get_userdatabylogin($sanitized_user_login);
$user_id = $user->ID;

// 自动登录
wp_set_current_user($user_id, $user_login);
wp_set_auth_cookie($user_id);
do_action('wp_login', $user_login);
}
}
}
?>

3、在register.php文件中查找以下代码:


并在上述找到的代码下面插入以下注册表单代码:

/*
添加注册表单
代码来源: www.wpzhinan.com/jiaocheng/1789.html
*/
'.$error.'

'; } if (!is_user_logged_in()) { ?>
" class="wpzhinan-reg">

您已注册成功,并已登录!

'; } ?>

4、到网站后台创建并发布一个名为“登陆”的空白页面,需选择页面模板为“注册页面”,这个模板页面就是用上面代码所创建的。

至此,一个完整功能的前台注册页面就已经创建好了。至于登陆页面的创建方法与此类似,不过要简单的多了,本站原先已有过类似登录框的介绍,有需要的同学可以用网站搜索框搜索看看,就不在本文展开说明了。希望本文对你有所帮助!

本文地址:http://www.wpzhinan.com/jiaocheng/1789.html
版权申明:除部分代码外,本站内容均为原创,转载请注明来源,违者必究侵权责任!

相关推荐

WP_Image_Editor_Imagick 指令注入漏洞修复方法

Imagick组件爆出了超级漏洞,危害等级极高,直接导致大量使用Imagick组件的网站均 ...